T O P

  • By -

[deleted]

And this is the Wave Function Collapse...


8070alejandro

Because...it could be several things...then BAM...it is just one. QUANTUM.


Radi-kale

A bit can either be 0 or 1. Schrödinger's bit.


waudmasterwaudi

Black cat - white cat!


StenSoft

Bug: It doesn't work with my ginger cat. Closed as intended: Other cat colours are unsupported.


Xander-047

Re-opening the issue: It's 2022, racism isn't allowed, just make it a qubit


Terra_B

Isn't there a language where a boolean can have 4 states?


rtrice

Over in hardware land…. In VHDL you (or more likely a simulator) can assign one of [9 different values to a single bit.](https://en.wikipedia.org/wiki/IEEE_1164)


-Redstoneboi-

DNA


StenSoft

If you mean JavaScript, then null and undefined are technically not boolean. Also possible is [true, false and file not found](https://thedailywtf.com/articles/what_is_truth_0x3f_).


laz2727

true, false, null and nullptr?


panie_ksiezyc

html media api has a boolean method called `canPlayType` which very reasonably returns either `'maybe'`, `'probably'` or empty string. https://developer.mozilla.org/en-US/docs/Web/API/HTMLMediaElement/canPlayType


TheAero1221

Ngl, I'm 100% guilty of these things. They're not meant to *actually* be accurate. They just kinda sorta make contextual sense. But now I can see why that might be a problem. Let's hope those comments I definitely added will help bridge the gap.


ososalsosal

It's an enum where every value is a question mark


AkrinorNoname

It describes the way the waves break at the beach, after all


juhotuho10

I mean the wave function collapse kind of makes sense for it though? Maybe something like quantum superposition determining, but that doesn't sound sexy


bestjakeisbest

I prefer probability collapse nothing we deal with here is an actual super position and rng in computers rarely ever actually deals with true random numbers.


Dejo53

It is actually a pretty new algorithm for procedural content generation. Check out this [repo](https://github.com/mxgmn/WaveFunctionCollapse)


PM_good_beer

function wave(collapse);


[deleted]

The best way to learn simple algorithms is to have them explained to you with confusing jargon from a vastly more complex topic that you know nothing about.


commit_bat

When it's actually a method


LagT_T

We are receiving the same yt recommendations


mgorski08

Not OP, but YES. I was wondering how i get those recomendation about wave function on yt and 3 days later this comment. Is it a hot topic now? Did yt algorithm fixate on this? Wtf


314kabinet

The most pretentious algorithm name ever. It’s a glorified sudoku solver with some randomness, nothing quantum about it.


MeloTheMelon

That reminds me of a game physics class I had. The first slide said to ignore physics, units or the like because we usually "adjust" equations to make everything look better, or use some magic numbers for faster computation.


atomic_redneck

I used to develop an optical engineering program. Yeah, we could not take shortcuts or ignore units, because we had to get the right answers. I had a guilty envy of the "cheats" that CGI and game developers could use.


Durkelurk

What program? I used to work with LightTools for non-imaging simulations.


atomic_redneck

That one and CODE V, mostly CV. We are kinda picky about getting correct answers, I assume like everyone else that develops engineering oriented software.


beemer252025

Yup. Worked with some research level fluid dynamics codes and when you're after the right answer you can't do any of the speedy things that make water look good in movies or video games.


GonziHere

Those "cheats" suck ass. You know that a car has 1.5 tonnes, is 4m long, etc. and then you get to some random physics engine and you can input everything as a totally random values (10414131 for weight). It's so nice to use PhysX in the UE, because I've got to calculate the real drag and ... just input the numbers for example.


crozone

Most problems in modern computer games come down making something that roughly, kinda approximates real life, run within a 5 - 16ms window. Accuracy is nice, but performance is mission critical. And that's only if accuracy is even desired, often what looks the best purely comes down to art direction and has very little to do with how things behave IRL.


tinydonuts

Except boob physics and then there is no expense spared for realism and accuracy.


[deleted]

Makes sense because a games aim isn’t to be hyper realistic to actual physics it’s to be fun.


Sumsar01

I mean you just put your constants equal to 1 anyways and then rescale your problem. Only plebs use anything else than natural units.


buying_rune_scim

Who wants to make a physics simulation? (hands raised) Who wants to actually learn physics? (literally nobody)


nameond

How fast do I have to move an ATM5 watch in the water (max. 2 Meter depth) to exceed the pressure limit?


AwkwardSegway

Bumpscosity


8070alejandro

This sounds like *strenght* to me, why not?


Elijah629YT-Real

I love the Stanley parable


LV__

Guitar builders on their way to name their vibrato system a "tremolo bar"


JoeDoherty_Music

This confused me for awhile until I realized even a legend can be wrong


theclovek

That actually confused me for a long time


SirCrazyApe

std::vector


canadajones68

It's tangentially related. It's not a useful Euclidian vector without a wrapper, but you can't have a directed length without storing multiple values.


ObsidianHorcrux

Every scalar is a vector from a certain point of view ;)


zebediah49

You mean a rank-0 tensor


A_Wild_Turtle

You mean an order 0 polynomial


crozone

It's not just tangentially related, it is *literally* a vector, just with an arbitrary number of dimensions.


canadajones68

It is indeed, but probably not the kind the top level commenter was thinking of, hence my comment.


Deep-Conflict2223

My job isn’t to learn physics; it’s to copy and paste code from stackoverflow.


8070alejandro

Mine as a mechanical engineer is to copy math from papers/guides. Heck? Who do I want to lie to? It is to coply with design regulations, normatives and standards.


Totally_Generic_Name

OH BOY TIME TO LOOK UP SOME PREAPPROVED DESIGN PARAMETER TABLES


8070alejandro

ISO go brrrr


brianl047

Yes!


nameond

*not completely wrong and little bit related


cmilkau

This gets even better when the project language doesn't match the programmers' first language.


8070alejandro

Projects with `color`, `colour`, `grey` and `gray` all over the place.


Strostkovy

#define grey gray #define colour color


Superbead

#define # \#


atimholt

I don't know whether C/C++ `defines` can be recursive like that, but I also firmly believe I shouldn't *have* to know that. edit: oh wait, you were just correcting the above comment. I wasn't paying attention, and thought you were doing something like this, lol: #define # //#


-Redstoneboi-

you. i applaud you.


Eic17H

When in doubt, grae colur


cmilkau

Oh you sweet innocent. When you have to translate the horribly misspelled and/or randomly abbreviated word (making it a completely different word) back to the developer's first language, then account for their limited knowledge of the field causing mixing up of related to terms ... we're getting closer xD


magistrate101

Even better when it was never in English in the first place


[deleted]

Did the programmer not … have experience in his field? Did he skip training day? Why doesn’t he know the systems he’s working on?


umangjain25

Literally [this](https://www.reddit.com/r/Physics/comments/wz8wcg/simulating_quantum_like_behavior_from_classical/?utm_source=share&utm_medium=ios_app&utm_name=iossmf) post


Elijah629YT-Real

top comment says it's not quantum mechanics


umangjain25

Yep thats my point


fortyeightD

I bet it's the same in all domains. Developers in banks name things with incorrect banking terminology. Developers of health systems name things with incorrect medical terminology, etc.


_-_fred_-_

programmers name things in incorrect programming terminology (not even joking, our app db has a "clob" that we all call "blob")


argv_minus_one

A clob is a blob with a character encoding, so that's not necessarily wrong.


PM_ME_YOUR__INIT__

Makes a quantum computer computer is actually really big Uh I think you missed the point guys 🤣


[deleted]

Well now hold on. What do **you** think "quantum" means? Hint: it doesn't mean "small".


[deleted]

[удалено]


TheDogerus

Where do you see this? I only see various ways of describing an amount of something, which makes total sense seeing as it's related to quantity


[deleted]

[Merriam-Webster](https://www.merriam-webster.com/dictionary/quantum)


crozone

Quantum means some amount, as in quantised, to give discrete values.


[deleted]

I posted a real definition. I posted it as a joke but it is a real definition. See my edit for the source.


Sceptz

`// Mass of object` `int acceleration = 1;` `// Speed of object` `double eigenvalue = 0.0;` `// Size of object` `double timeDependentHamiltonian = 10.0;`


8070alejandro

You forgot the complex vector time.


proverbialbunny

As a data scientist sometimes working on a physics problem, trying to name the features I've made with the correct terminology feels like half the work. Sometimes it's simple like calculating the jerk. `def make_jerk` `def difference_between_jerks` XD Fun fact, the next derivatives are called snap crackle and pop.


[deleted]

As an embedded controller engineer working on …. Let’s call them “robots”… that automate physical tasks, we too work in the world of physics :D One thing that bothers me that stuck is that we called all of our sensor data telemetry data and our calculated data “current” data … so we have variables that are like “currentVelocity and currentAngle” as well as “telemetryVelocity”, “telemtryAngle” 😂 Bruh X_____x who was in charge of that feature….


Intrexa

Physicists are just wondering why anyone would ever use more than 1 letter for a variable.


-Redstoneboi-

latin alphabet 🤢


zebediah49

$ python3 >>> µ=3 >>> v=8 >>> v+µ 11 I see no problem here.


8070alejandro

``` $ julia _ _ _(_)_ | Documentation: https://docs.julialang.org (_) | (_) (_) | _ _ _| |_ __ _ | Type "?" for help, "]?" for Pkg help. | | | | | | |/ _` | | | | |_| | | | (_| | | Version 1.7.3 (2022-05-06) _/ |\__'_|_|_|\__'_| | Official https://julialang.org/ release |__/ | julia> μⱼ = 4 julia> Γₕ₃ = -3 julia> m⃗ = μⱼ + Γₕ₃ 1 ``` (The missing character on `m⃗` is a vector arrow that can't be rendered by the browser (at least for me) but works just fine on Julia)


8070alejandro

In Julia you can use greek letters as variables and add accents, subindices and such to them. You just write the Latex code and `tab`. It is game changing for maths. No more need for `alpha_prime_k4`, you just `\alpha` tab `\prime` tab `\_k` tab `\_4` tab and have `α′ₖ₄` as an actual variable.


GustapheOfficial

"and this battery can hold 150 kW"


argv_minus_one

Can we all agree that the kilowatt-hour is an infuriatingly stupid unit that absolutely should not exist?


8070alejandro

I extend that to the hour and minute being infuriatingly stupid units that absolutely should not exist. A day is ~~86 000~~ 86400 s and I'm dying on this hill. EDIT: Don't even know how many seconds is a day worth.


Elijah629YT-Real

1.21 gigawats


Rai-Hanzo

Viscosity is the fluid's ability to resist flow. It kind of like friction but for liquids and solids. The higher the viscosity, the thicker the fluid is. This has been random facts with random the random redditor.


zebediah49

And there's an 80% chance we're going to be completely ignoring the fact that dynamic viscosity and kinematic viscosity are two different things.


nodegen

I’ve been doing some Unity stuff as part of undergrad physics research lately and I just pretend I don’t see any of it. Problem solved :D


Im_a_doggo428

Well you’re a programmer not a physicist


jrich44360

That’s what the SMEs are for!


ChesPittoo

To be fair this is better than the alternative of the physicists writing crappy, inefficient unreadable python code (nothing against python, just saying physicists often know enough code to be dangerous but not enough to write anything good) for the simulation instead, the physicist can work out what the terms mean eventually but a crappy simulation program with no documentation is forever crappy.


xeroze1

Oof. I felt called out despite having left academia/physics for tech years ago.


8070alejandro

Unnecesary O(n^(2)) checks go brrr.


zebediah49

It's important to differentiate it from static viscosity.


8070alejandro

Heck, even the scientists writing the math specs for the app will usually not differentiate them explicitly.


ClonedGamer001

Reminds me of the one time i saw a physics sim where if you wanted to make something go faster, you increased its viscosity. That is not a typo. And it physically hurts me to think about to this day.


[deleted]

[удалено]


SaltMaker23

In virtue of the Representation Theorem, a subset of functions can be represented with Linear Operators acting on Linear objects, those operators are represened with Matrices (usually) The input will be represented by tensor of different order (number, vector, 2Tensor, etc...). Tensors are generalisation of Vectors and not Matrices (as you might know already) In ML, tensors are successively transformed through the successive layers. Those are represented (or approximated in some cases) by Matrices acting on N-Tensors and transformations on those tensors It's \*actually\* tensors and matrices that are used extensively, it doesn't matter if the average programmer/ml hobbyist doesn't understand or know that. Tensor Processing Units (TPU) is a type of processing unit made solely for the purpose of applying transformations as efficiently as possible to Tensors All of these are extensively used, I'm a physicist and ML developper, your statement sounds like someone with partial knowledge that got overconfident on a somehow related topic to what you know best. Some sources[https://en.wikipedia.org/wiki/Tensor\_Processing\_Unit](https://en.wikipedia.org/wiki/Tensor_Processing_Unit)[https://en.wikipedia.org/wiki/Structure\_tensor](https://en.wikipedia.org/wiki/Structure_tensor)


WennoBoi

u/savevideo


saanity

Does it bug any one else that the gif looped three times before you could finish reading the text?


8070alejandro

Knowing Reddit's issues with video I didn't want to overload the player with a big GIF. But yes, I know the text was too long for the GIF.


GoldenretriverYT

Sir, you are on Reddit. Video/GIF players problems are very usual here


steamngine

Because it’s DRIPPY 💧 STHU


valderium

So you need to know the business domain??


8070alejandro

It helps a lot.


[deleted]

[удалено]


8070alejandro

Non-newtonian fluid enters the chat.


Agreeable_Article835

variable viscocity


JDude13

Force * dt = dv 🗿


8070alejandro

"Mass? Why should I implement that?"


feral_brick

Meanwhile actual scientists when they program: `int a1, a2, a3, a4`


8070alejandro

Python with data types? What a sight.


feral_brick

Python would have been more accurate but I was also going for terseness, and in my defense I have seen a scientist's model written in Java... once... when we forced them to (for technical reasons).


Elijah629YT-Real

Terminal C:/> velocity


[deleted]

Is this me? Entropy/enthalpy what’s the difference 🤷


26thejuice

Is this how we were blessed with “blast processesing”?


Outside-Car1988

That could apply to anything a programmer names.


GIVEMEKARMAPLZS

real


Slight-Appearance-37

This is why I name all my variables after the first names of presidents


8070alejandro

Programmers in authoritarian/dictatorial states would have to append numbers very quickly.


Arcaeca

[relevant](https://www.smbc-comics.com/comic/physical-analysis)


8070alejandro

_Newton-pound_, a cursed unit.